Перейти на главную страницу ~GAMETITLE~

Важные новости

12.01.2021, 11:46

Уважаемые игроки!
Начиная с версии лаунчера 1.0.25 запуск игры с более ранних версий лаунчера будет невозможен. Версия лаунчера 1.0.28, и все последующие, будут самостоятельно проверять актуальность версии и выполнять обновление.

Если вам надо заново установить лаунчер - взять его можно на сайте игры
https://www.northernblade.ru

Опрос

Как вы оцениваете работу технической поддержки?
  1. 5 (Очень хорошо)
    31%
  2. 4 (Хорошо)
    13%
  3. 3 (Так себе)
    10%
  4. 2 (Плохо)
    4%
  5. 1 (Очень плохо)
    18%
  6. Не обращался
    23%
Всего проголосовало: 5656